UBUNTU-WEBSDR NOVICE

Here we will discuss only topics related to the YO3GGX's WebSDR servers
Post Reply
IZ0PMV
Posts: 3
Joined: Fri Jul 05, 2013 11:11 pm

UBUNTU-WEBSDR NOVICE

Post by IZ0PMV »

Hello to all
My name is Emanuele and my call is IZ0PMV
I am 41 years old and live in Ariccia small village 20km south-east of Rome.
Besides a radio to my other passion is latin-american music.
I speak Spanish also,
For English, I'm organizing!

Well after this short presentation I will explain my problem
I decided to put online a SDR receiver Softrock Ensemble II HF
The S.O. is Ubuntu 14.03 with the software WebSDR of G.F. PA3FWM with sound card Xonar D1.E so far so good.

Now the problems:
1) The sound card. The card is detected easily with alsamixer but if I act on the volume levels do not get nessuma varione audio.
Same thing if I act using the "AUDIO" on the control panel (pass this description).

question:
This duccede for the lack of software dedicated to XonarD1?



2) Output I / Q.
PA3FWM told me to be using the command "swapiq" to solve the sound problem as in the image attached.
here I definitely need your help to compile the command line to activate the I / Q to avoid the reflection of the audio spectrum.

I will stop here for the moment.

Thanks for your contribution.

Emanuele IZ0PMV
Attachments
WEBSDR.png
User avatar
yo3ggx
Site Admin
Posts: 753
Joined: Wed Aug 15, 2012 8:30 pm
Location: Bucharest, România
Contact:

Re: UBUNTU-WEBSDR NOVICE

Post by yo3ggx »

Hi Emanuele,

First I want to thank you for joining this group.
IZ0PMV wrote: Well after this short presentation I will explain my problem
I decided to put online a SDR receiver Softrock Ensemble II HF
The S.O. is Ubuntu 14.03 with the software WebSDR of G.F. PA3FWM with sound card Xonar D1.E so far so good.

Now the problems:
1) The sound card. The card is detected easily with alsamixer but if I act on the volume levels do not get nessuma varione audio.
Same thing if I act using the "AUDIO" on the control panel (pass this description).
You're right. Same for me, but luckily the volume is ok for me as it is.
In a previous version of fedora there was an utility named gmixer, able to control the volume for the Xonar card.
2) Output I / Q.
PA3FWM told me to be using the command "swapiq" to solve the sound problem as in the image attached.
here I definitely need your help to compile the command line to activate the I / Q to avoid the reflection of the audio spectrum.
This is not because of swapping channels, but because you have a mono audio signal (only one of the channels or the two channles are conncted in parallel.
Check the cables and the input (not to be mono).
From the Softrock side disconnect left channel to see if is something changed then connect it back and disconnect right channel.

Good luck,
Dan YO3GGX
IZ0PMV
Posts: 3
Joined: Fri Jul 05, 2013 11:11 pm

Re: UBUNTU-WEBSDR NOVICE

Post by IZ0PMV »

Hello Dan
as I am ashamed!!

The cable is mono! (see immaggine)
I never thought the cable.
Now it seems to work properly.

you can access the WebSDR to address iz0pmv.no-ip.net
I state that I am doing the tests, so it is not always on line

Thanks for the solution


I am now another question:
I have a second receiver but LF
how do I change the "multiplier" from 4 to 16 so that it will operate at 500 KHz?

I tried using the command line
set si570_multiplier [band] <decimal factor>
but I have not seen changes



COMMAND
calibrate (may require -s option)
getfreq
getregisters
interactive
getptt (-h option for Mobo only)
getkeys (PE0FKO+TF3LJ+Mobo)
ptt {on|off}
set bpf {on|off} (PE0FKO+TF3LJ+Mobo)
set bpf_addr <band> <filter> (PE0FKO >= 15.12+Mobo)
set bpf_point <crossover> <f in MHz> (PE0FKO+TF3LJ+Mobo)
set lpf {on|off} (TF3LJ+Mobo only)
set lpf_addr <band> <filter> (TF3LJ+Mobo only)
set lpf_point <crossover> <f in MHz> (TF3LJ+Mobo only)
set freq <frequency in MHz>
set si570_addr <i2c address in decimal>
set si570_multiplier [band] <decimal factor> (PE0FKO>=15.12+Mobo)
set startup <frequency in MHz> (PE0FKO+TF3LJ+Mobo)
set xtall <frequency in MHz> (PE0FKO+TF3LJ+Mobo)
status


73 Emanuele IZ0PMV
Attachments
Cavo.png
Cavo.png (101.12 KiB) Viewed 11017 times
User avatar
yo3ggx
Site Admin
Posts: 753
Joined: Wed Aug 15, 2012 8:30 pm
Location: Bucharest, România
Contact:

Re: UBUNTU-WEBSDR NOVICE

Post by yo3ggx »

Hi Emanuele,
IZ0PMV wrote: The cable is mono! (see immaggine)
I never thought the cable.
Now it seems to work properly.
Great!
you can access the WebSDR to address iz0pmv.no-ip.net
I state that I am doing the tests, so it is not always on line
I have tried but is not accessible.
I am now another question:
I have a second receiver but LF
how do I change the "multiplier" from 4 to 16 so that it will operate at 500 KHz?

I tried using the command line
set si570_multiplier [band] <decimal factor>
but I have not seen changes

73 Emanuele IZ0PMV
Unfortunately I don't have experience with the LF version so I cannot give you any advice.

73 Dan YO3GGX
IZ0PMV
Posts: 3
Joined: Fri Jul 05, 2013 11:11 pm

Re: UBUNTU-WEBSDR NOVICE

Post by IZ0PMV »

Hello and good Sunday
Dan thank you for the answers
you are right in saying that the IP address does not work
because it is .biz and not .net

iz0pmv.no-ip.biz

73,
Emanuele IZ0PMV
Post Reply